Bug 63 - The ":" character is stripped from filenames
Summary: The ":" character is stripped from filenames
Status: RESOLVED WONTFIX
Alias: None
Product: Asunder
Classification: Unclassified
Component: All (show other bugs)
Version: 2.9.3
Hardware: PC Linux
: normal
Assignee: Andrew Smith
URL:
Depends on:
Blocks:
 
Reported: 2019-12-07 09:39 EST by Dan Rawson
Modified: 2019-12-09 14:01 EST (History)
2 users (show)

See Also:


Attachments

Description Dan Rawson 2019-12-07 09:39:49 EST
If data like track or album names contain a ":" character, that character is stripped from the created file name, but still appears in the metadata.  As an example, I have the following track name (retrieved from freedb in this case):

"Concerto for 2 Trumpets & Strings in C major, RV 537: 1. Allegro"

Using "%N. %T" as the filename spec in asunder, I get:

"01. Concerto for 2 Trumpets & Strings in C major, RV 537 1. Allegro.flac"

as the generated file name.  The FLAC metadata still shows the original string as the "TITLE" tag.

AFAIK the ":" character is legal on Linux

System is OpenSUSE 15.1 with all current patches.  Asunder version is actually 2.9.3, but it's not in the above list :-)
Comment 1 Andrew Smith 2019-12-07 18:38:34 EST
Hi Dan

Thanks for the report. But I'm missing what you're suggesting. The ":" character is actually valid on Linux but it isn't on windows, and some portable players. Therefore it's removed on purpose from the filenames but left alone in the metadata where the filename restriction does not apply.

Please let me know if I'm missing something.

Andrew
Comment 2 Dan Rawson 2019-12-07 19:11:49 EST
Andrew -

Thanks - I know the ":" is prohibited in Windows file names, but I didn't realize that some portable players also had this restriction.  I've been ripping a large collection of classical CD's, and the ":" is _very_ common in those track names.  Mostly I manually update the track names from what I get from freedb so that I'm using a different character.

I guess in a perfect world :-) I could keep them since I'm on Linux - but it sounds like that would require a separate codebase . . . 

In the course of searching on the net, I also discovered that ":" is illegal in Mac OS 9 - who knew?

Now that I understand the limitations, I assume this can get marked as "Not a bug"

Thanks!!

Dan

Note You need to log in before you can comment on or make changes to this bug.