Bug 52 - Respect XDG Base Directory Specification
Summary: Respect XDG Base Directory Specification
Status: RESOLVED DUPLICATE of bug 31
Alias: None
Product: Asunder
Classification: Unclassified
Component: All (show other bugs)
Version: 2.9.2
Hardware: PC Linux
: enhancement
Assignee: Andrew Smith
URL:
Depends on:
Blocks:
 
Reported: 2018-01-04 07:41 EST by Oliver Kahrmann
Modified: 2018-01-05 07:58 EST (History)
3 users (show)

See Also:


Attachments

Description Oliver Kahrmann 2018-01-04 07:41:51 EST
Currently, asunder stores 4 files directly in $HOME:
    .asunder
    .asunder_album_artist
    .asunder_album_genre
    .asunder_album_title

To follow the XDG Base Directory Specification, these should not be there. Following the specification is useful to allow easier separation of caches, configuration and data files - Especially useful in backup scripts, among other things.

The first one is the main config file from what I can tell, so it should be in $XDG_CONFIG_HOME/asunder (defaulting to $HOME/.config/asunder).

The other three are autocompletion data and/or caches. Since there is value to keeping them around (they provide useful functionality that is lost when they are deleted) they should be located in $XDG_DATA_HOME/asunder (defaulting to $HOME/.local/share/asunder) rather than $XDG_CACHE_HOME which is considered disposable.
Comment 1 Oliver Kahrmann 2018-01-04 07:44:10 EST
The XDG Base Directory specification can be viewed here: https://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html
Comment 2 Gregory Margo 2018-01-04 23:01:00 EST
XDG base directory issues were addressed in patches r367 and r368,
which occurred between versions 2.8.1 and 2.9.

If you are using version 2.8.1 or earlier, you'll have the old config setup.
Newer versions convert to the new config but do not delete the old config files.

See bug 31 for more details.
Comment 3 Oliver Kahrmann 2018-01-05 07:58:44 EST
Oh, I see. thank you for explaining!

*** This bug has been marked as a duplicate of bug 31 ***

Note You need to log in before you can comment on or make changes to this bug.